国开学习网《数据库运维》第1章本章自测答案
数据库系统的核心是()。
【答案】数据库管理系统
以下不属于数据库特点的是()。
【答案】数据冗余度高
哪个选项是用来创建和修改数据库结构的()。
【答案】DDL
数据库中数据的逻辑独立性是指()。
【答案】数据与程序之间的逻辑相互独立
要保证数据库的数据独立性,需要修改的是()。
【答案】三级模式之间的两层映射
在数据库系统中,负责监控数据库系统的运行情况,及时处理运行过程中出现的问题,这是()人员的职责。
【答案】数据库管理员
MySQL数据库运维中系统高可用性,其中年度可服务时间比例“5个9”,其年度停机时间大约为()。
【答案】5min
mysqladmin为用户root设置密码的语句()。
【答案】mysqladmin-urootpassowrd“NEWPASSWORD”
mysqladmincommand参数中删除一个库的参数是()。
【答案】drop[DB_NAME]
mysqlbinlog中使用参数()可以打开指定库的binlog文件。
【答案】-d
MySQL可视化管理工具MySQLGUITools中方便数据库迁移的图形化应用程序是()。
【答案】MySQLMigrationToolkit
广义上来说,属于数据的可以是()。
【答案】 数字,文本,图像,音频
数据实现集中控制,包括()。
【答案】 安全性控制,完整性控制,并发控制
数据库管理系统的主要功能包括()。
【答案】 数据定义功能,数据操作功能,数据库的运行管理,数据库的建立和维护
以下属于数据库系统运维的主要内容的是()。
【答案】 数据库安装与配置,数据库安全性管理,数据库备份与恢复,预防性巡检
数据库系统日常的运维管理中包括日维护作业计划,以下属于日维护作业计划的是()。
【答案】 检查数据库网络连通与否,检查磁盘空间的使用情况,监视数据库的表空间利用率
以下是MySQL数据库运维的指标的是()。
【答案】 数据可恢复性,系统高可用性,成本问题
试述数据库系统的组成。
【答案】数据库系统(DBS):是由数据库和数据库管理软件组组成。具体来说是由数据库、硬件、软件和人员四个部分组成。数据库(DB):概括的说就是按照数据结构来组织、存储和管理数据的仓库。官方的定义一般是:是一个长期存储在计算机内的、有组织的、有共享的、统一管理的数据集合。它实际上时一个按数据结果来存储和管理数据的计算机系统。数据库管理系统DBMS是数据库软件的核心,主要是实现对共享数据的有效组织,管理和存储。
MySQL数据库运维的五大指标具体是什么?
【答案】(1)数据的可恢复性。有些时候也说成数据可靠,数据库运维人员的首要职责是必须保证不丢数据;(2)系统高可用性。系统高可用性提供稳定服务的时间,即年度可服务时间比例要高。(3)响应时间。响应时间是指一条查询或者更新语句从发出请求到接收完数据的时间。对于一般应用来说,在50ms内返回是比较理想的结果,超过200ms的查询可以视为慢查询。(4)成本问题。数据库系统的成本主要是硬件成本+软件成本+人力成本,如何提高硬件或者软件的使用率,降低人工运维成本,提高人均产出,就是成本问题的目标。(5)运维人员的幸福指数。运维的很多工作需要人工来完成,为了体现运维的人文关怀,必须加入运维人员幸福指标。运维人员的幸福指数可以从以下三个方面考量。①人均承担数据库读写量(如果数据库读写量大,这个值低,那么必然是运维人员多,人均产值/薪酬低)。②运维人员长期从事机械化的、重复性工作的时间比例。③运维人员在工作时间以外进行切换上线、故障处理的时间比例。
写出5条使用mysqladmin命令行工具的语句。
【答案】mysqladmin工具的使用格式:
mysqladmin[option]command[command]command
查看服务器的状况:status:mysqladmin-uroot-pstatus;
显示服务器所有运行的进程:mysqladmin-uroot-pprocesslist;
结束进程:mysqladmin-uroot-pkillidnum;
使用安全模式关闭数据库:mysqladmin-uroot-pshutdown;
清空线程缓冲池:mysqladmin-uroot-ppasswordflush-threads。
国开学习网《数据库运维》第2章本章自测答案
1.MySQL使用的默认端口是()。
A.3600
B.3306
C.8080
D.3366
2.连接MySQL服务器的指令是()。
A.mysqladmin-urootpasswordtest
B.mysql-urootpasswordtest
C.mysql-uroot-ptest
D.mysql-uroot-passwordtest
3.下面哪个是MySQL客户端程序的功能?()
A.创建、删除、修改表和索引
B.使用shutdown命令关闭服务器
C.使用startbackup命令来进行数据库二进制备份
D.查询数据库日志文件信息
4.MySQL服务器的存储引擎中支持事务处理、支持外键、支持崩溃修复能力和并发控制的存储引擎是()。
A.InnoDB
B.MyISAM
C.Memory
D.NDB
5.SQL标准中事务的四种隔离级,MySQL数据库的InnoDB存储引擎中默认采用的是()。
A.未提交读(ReadUncommitted)
B.提交读(ReadCommitted)
C.可重复读(RepeatableRead)
D.可串行化(Serializable)
6.在MySQL数据库中,InnoDB无法向MyISAM表一样,直接将表定义文件*.frm和*.ibd复制到另一个库中的原因是()。
A.InnoDB的锁机制是行机制
B.InnoDB系统表空间文件ibdata1中存放着回滚段、所有的InnoDB表元数据信息等部分元数据信息
C.InnoDB的表定义文件与MyISAM表定义文件不同
D.InnoDB复制过程中日志文件无法复制
7.MySQL数据库中,关于作为临时存放查询的中间结果集的存储引擎描述正确的是()。
A.始终使用Memory作为临时存放查询的中间结果集
B.默认使用InnoDB作为临时存放查询的中间结果集
C.如果中间结果集含有TEXT或BLOB列的类型字段,则MySQL数据库会将其转换到MyISAM存储引擎表而存放到磁盘中
D.默认使用MyISAM作为临时存放查询的中间结果集
8.MySQL数据库通过命令行参数和配置文件来获得配置信息,查看当前使用的配置文件路径的DOS命令是()。
A.select@@basedir
B.select@@datadir
C.mysql-verbose-help
D.select@@my.ini
9.MySQL数据库中创建表并指定MyISAM存储引擎的语句是()。
A.Createtablet_myisam(idint(10)auto_increment,namevarchar(10),ageint(3),primarykey(id));
B.Createtablet_myisam(idint(10)auto_increment,namevarchar(10),ageint(3),primarykey(id))setengine=MyISAM;
C.Createtablet_myisam(idint(10)auto_increment,namevarchar(10),ageint(3),primarykey(id)),MyISAM;
D.Createtablet_myisam(idint(10)auto_increment,namevarchar(10),ageint(3),primarykey(id))engine=MyISAM;
10.在配置MySQL服务器时缓存池的大小设置,下面正确的是()。
A.缓冲池大小可以设置的很大,以保证数据库的性能
B.缓冲池的大小设置为系统内存剩余空间最好
C.缓冲池的配置,不仅要兼顾系统中其他程序使用的内存空间,还要减去其他配置的MySQL缓存和缓存需要的内存空间
D.缓冲池大小的设置对性能产生很大的影响,所以要设置成最大
11.MySQL内部有4种常见日志,哪种日志是不能直接cat或more文件查阅日志内容()。
A.错误日志(error-log)
B.二进制日志(bin-log)
C.查询日志(query-log)
D.慢查询日志(slow-log)
12.MYSQL中,下列关于慢查询日志描述正确的是()。
A.慢查询日志不仅记录执行慢的查询,而且会将所有执行的查询语句都记录下来
B.在通过环境变量开启慢查询日志时,slow_query_log针对当前登录的连接实时生效
C.在通过环境变量开启慢查询日志时,long_query_time针对当前连接生效(query-log)
D.慢查询文件已.ini格式的文件格式存储
13.在mySQL数据库中,数据库文件的扩展名包括()。
A..exe
B..myi
C..ibd
D..frm
14.MySQL数据库中,存储引擎InnoDB的功能特点有()。
A.支持事务的提交和回滚
B.崩溃修复能力
C.并发控制
D.数据可压缩
15.MySQL数据库中,关于Memory存储引擎描述正确的是()。
A.默认使用哈希索引
B.MySQL使用Memory存储引擎作为临时表来存放查询的中间结果集
C.支持外键和事务处理
D.将表中数据存放在内存中
16.MySQL中,下面可以查看Country表的存储引擎的是()。
A.SHOWCREATETABLECountry;
B.SHOWENGINECountrySTATUS;
C.SHOWTABLESTATUSLIKE‘Country’;
D.SELECTENGINEFROMINFORMATION_SCHEMA.TABLESWHERETABLE_NAME=‘Country’;
17.MySQL中,对二进制文件的功能描述正确的是()。
A.主从数据库通过二进制文件的传递达到主从同步目的
B.二进制文件可用于数据恢复,通过应用二进制日志文件,能够将数据库恢复到故障发生前的状态
C.数据库运行过程中的错误信息,也会被记录到二进制文件中,以便数据库恢复正常
D.二进制文件中记录了数据库查询语句以及其运行时间,可用于服务器性能的优化
18.关于临时表的描述正确的是()。
A.只在创建的会话可见,其它会话不能访问另一个会话创建的临时表
B.临时表只存在于会话生命周期中
C.临时表可以与非临时表有相同的名称
D.临时表不能使用SHOWTABLES显示
19.关于MySQL服务器内存管理叙述正确的是()。
A.MySQL数据库的内存从使用方式上主要分为以下两类:线程独享内存(Threadmemory)和全局共享内存(Sharing)
B.线程独享内存主要用于各客户端连接线程存储各种操作的独享数据
C.全局共享内存主要是MySQL实例(mysqld进程)以及底层存储引擎用来暂存各种全局运算及可共享的暂存信息
D.全局共享内存包括thread_stack、sort_buffer_size等
20.请陈述MySQL服务器中,数据库和数据库实例的概念。
21.登记日志文件时为什么必须先写日志文件,后写数据库?
22.如何为InnoDB存储引擎配置合理大小的缓冲池?并举例说明。
国开学习网《数据库运维》第3章本章自测答案
1.视图建立后,在数据字典中存放的是( )
A.视图的定义
B.产生视图的表的定义
C.查询语句
D.组成视图的表的内容
2.查找数据库中所有的数据表用以下哪一项( )
A.SHOWDATABASE
B.SHOWTABLES
C.SHOWDATABASES
D.SHOWTABLE
3.创建数据库的命令是()
A.CREATEDATABASE
B.NEWDATABASE
C.CREATEDATABASES
D.NEWDATABASES
4.以下关于聚集索引和非聚集索引说法正确的是( )
A.每个表只能建立一个非聚集索引
B.每个表只能建立一个聚集索引
C.一个表上不能同时建立聚集索引和非聚集索引
D.以上都不对
5.在视图上不能完成的操作是( )
A.更新视图
B.查询
C.在视图上定义新的表
D.在视图上定义新的视图
6.若要在基本表中添加一列CNAME(课程名),可用( )
A.ADDTABLES(CNAMECHAR(8))
B.ADDTABLESALTER(CNAMECHAR(8))
C.ALTERTABLESADD(CNAMECHAR(8))
D.ALTERTABLES(ADDCNAMECHAR(8))
7.在关系数据库中,为了简化用户的查询操作,而又不增加数据的存储空间,常用的方法是( )
A.另一个表
B.游标
C.索引
D.视图
8.关于索引正确的说法是( )
A.使用索引可以提高数据查询速度和数据更新速度
B.使用索引可以提高数据查询速度,但会降低数据更新速度
C.使用索引可以提高数据查询速度,对数据更新没有影响
D.使用索引对数据查询速度和数据更新速度都没有影响
9.以下表示可变长度字符串的数据类型是( )
A.CHAR
B.VARCHAR
C.TEXT
D.BLOB
10.下列关于数据库对象的描述,错误的是( )
A.存储过程、函数均可接收输入参数
B.触发器可以在数据更新时被激活
C.域可以由用户创建,可以加约束条件
D.一个关系可以有多个主码
11.在MySQL数据库中,下列关于创建数据库表的描述不正确的是( )
A.在创建表时必须设定列的约束
B.在删除表的时候通过外键约束连接在一起的表会被一同删除
C.在创建表时必须设置列类型
D.通过CREATETABLEnew_tSELECT*FROMold_t复制表的同时,表的约束能够一起被复制到新表中
12.MySQL中可以创建的索引有( )
A.聚簇索引
B.普通索引
C.主键索引
D.全文索引
13.关于临时表的描述正确的是( )
A.只在创建的会话可见,其它会话不能访问另一个会话创建的临时表
B.临时表只存在于会话生命周期中
C.临时表可以与非临时表有相同的名称
D.临时表不能使用SHOWTABLES显示
14.创建唯一性索引的方法有( )
A.设置主键约束
B.CREATEINDEX
C.设置非空约束
D.CREATETABLE
15.更新视图是指通过视图对数据进行( )操作
A.插入
B.删除
C.修改
D.查询
16.图书管理系统中有book表,book(bookid,bookname,authors,info,comment,year_publication);
(1)给book表的bookname字段添加索引
17.(2)在book表的bookid字段上建立名称为id_idx的唯一索引
18.(3)在book表的info和authors字段上创建组合索引
19.(4)在book表的info字段上建立全文索引
国开学习网《数据库运维》第4章本章自测答案
1.关于自主访问控制,下列说法错误的是()。
A.S表示主体,即操作用户
B.O表示客体,即数据
C.M表示数据库基本的查询、修改、添加、删除等操作
D.P元素用来表示操作语句具体内容
2.权限表中User表的作用是( )。
A.存储用户对某数据库的操作权限
B.存储了某主机对数据库操作的权限
C.表示存储过程和存储函数操作权限约束
D.记录允许连接到服务器的账号信息和与账号信息对应的权限规范
3.以下哪个命令是使用超级管理员身份创建普通账户()
A.createuserusername@localhostidentifiedby123456
B.createuser‘username’@‘localhost’identifiedby123456
C.createuserusername@localhostidentifiedby‘123456’
D.createuser‘username’@‘localhost’identifiedby‘123456’
4.下列Mysql权限表中,只存在用户列和权限列,对表级别设置权限的是()。
A.columns_priv权限表
B.table_priv权限表
C.db权限表
D.procs_priv权限表
5.使用grantselectontable.*tousername@localhost语句时如果table不存在会如何响应()
A.显示请选择其他数据库
B.显示查询成功并创建表
C.只显示查询成功
D.显示表不存在请重新查询
6.用于控制用户对数据库表建立或删除索引的权限为()。
A.select权限
B.index权限
C.alter权限
D.create权限
7.例如数据库中有grade表,包括学生,学科,成绩,序号四个字段,数据库结构为
学生 学科 成绩序号
张三 语文 60 1
张三 数学 100 2
李四 语文 70 3
李四 数学 80 4
李四 英语 80 5
上述哪一列可作为主键列( )
A.序号
B.成绩
C.学科
D.学生
8.下列属于数据层级操作权限的是()。
A.select权限、insert权限、update权限、delete权限
B.select权限、index权限、update权限、alter权限
C.select权限、drop权限、update权限、grant权限
D.select权限、index权限、create权限、delete权限
9.MySQL权限系统对用户可操作行为的认证说法不正确的是( )。
A.需要通过用户名密码以及IP与数据库记录相匹配
B.如果用户名和密码都匹配,IP不匹配,用户仍可继续访问
C.需要对通过验证的用户进行权限匹配,赋予其应有权限
D.不同IP登入的用户,同名用户属于不同的身份
10.关于限制MySQL账户资源次数,表示限定每小时内该用户账户向MySQL服务器发送查询语句或者mysql命令的最大允许次数的是()。
A.max_questions
B.max_updates
C.max_updates
D.max_user_connections
11.Mysql权限层级中用户层级相当于()。
A.全局层级
B.数据层级
C.子程序层级
D.列层级
12.为数据表创建索引的目的是( )。
A.提高查询的检索性能
B.归类
C.创建唯一索引
D.创建主键
13.假定登录用户只有GRANT权限,username3@localhost不存在,执行语句:“GRANTSELECTON*.*TOusername3@localhostIDENTIFIEDBY‘123456’WITHGRANTOPTION;”时,Mysql如何反应( )。
A.操作被拒绝
B.操作被接受并创建username3@localhost用户
C.操作被接受但不执行任何改变
D.操作被拒绝并创建username3@localhost用户
14.MySQL中,在某表内除主键以外的某一列,每一元组该列的取值都是唯一的约束类型为()。
A.主键完整性约束
B.唯一索引约束
C.完整性约束
D.替代键约束
15.MySQL服务器安装时,自动建立两个数据库,首先是mysql数据库,该数据库是MySQL权限系统的核心,包含以下哪几个表:()。
A.user表
B.db表
C.procs_priv表
D.tables_priv表
16.MySQL修改root用户密码的语法为( )。
A.mysqladmin–uuser_name–hhost_name–ppassword“new_password”;
B.INSERTINTOmysql.user(password,root,hostname)VALUES(PASSWORD(‘rootpassword’),”root”,”hostname”);
C.SETPASSWORD=PASSWORD('rootpassword');
D.UPDATEmysql.userSETpassword=PASSWORD('rootpassword')WHEREuser=”root”andhost=”host_name”;
17.下列对MySQL唯一索引约束描述正确的是()。
A.指的是在某表内除主键以外的某一列,每一元组该列的取值都是唯一的
B.可以当作没有被选作主键的候选键
C.UNIQUE子句来定义唯一索引约束
D.存在主键时唯一索引约束定义列可重复
18.关于外键说法正确的是()。
A.在一个数据表中定义了外键后,数据库系统会保证插入外键中的每一个非空值都在被参照表当中作为主键出现
B.使用RESTRICT动作时,将待插入的记录值相应外键字段改成其所参照表中不存在的数据值,插入操作会被数据库拒绝
C.使用SETDEFAULT动作时,从所参照父表删除或更新行时,删除在参照子表中对应的该外键值对应行或者对该行外键作同样的修改
D.使用CASCADE动作时,当所参照父表中试图删除某行或对外键列某行数据值进行更新,参照子表中不作任何反应动作
19.用户自定义完整性约束包括以下哪几种约束( )。
A.元组约束
B.关系间约束
C.替代键约束
D.域约束
20.关于MySQL列约束的下列描述中正确的有()。
A.主键约束会影响表的查找操作执行效率,应当谨慎使用
B.外键约束会影响表的插入操作执行效率,应当谨慎使用
C.一个表可以声明多个主键列
D.一个表可以声明多个外键列
21.登录root账户创建普通账户并给普通账户授权:
(1)创建一个密码为“123456”的普通用户账户“databasenormal”;
22.(2)创建名为student的数据库
23.(3)创建名为student2的表,包括stuno(学号列)、stubir(生日列)、age(年龄列),并设置主键为stuno
24.(4)使用grant命令对其进行student数据库的student2的表的stuno列的select操作授权;
25.(5)查看mysql数据库下user表中该用户的条目
26.(6)查看mysql数据库下table_priv表中该用户条目
27.(7)查看mysql数据库下columns_priv表中该用户条目
国开学习网《数据库运维》第5章本章自测答案
1.下面关于写日志优先准则描述正确的是()。
A.当数据库执行更新操作时,先把写日志和更新数据库同时进行
B.当数据库执行更新操作时,先更新数据库,然后再将更新信息写进日志
C.当数据库执行更新操作时,先把更新信息写进日志,然后更新数据库
D.当数据库执行更新操作时,先把更新信息写进日志,然后更新缓冲区
2.数据库中缓冲区写入磁盘使用的算法是()。
A.FIFO
B.LFU
C.ARC
D.LRU
3.适用通配符查看名称包含dir的系统变量的值( )。
A.showvariableslike‘dir’
B.showvariableslike‘%dir%’
C.showvariableslike‘%dir’
D.showvariableslike‘_dir_’
4.select…intooutfile语句中用于指定字段值之间符号的子句是()。
A.linesterminatedby
B.filedsterminatedby
C.filedsenclosedby
D.filedsescapedby
5.下面关于mysqldump命令使用正确的是( )。
A.mysqldump-uroot-p123456--databasesemployeestest>file.sql
B.mysqldump-uroot-p123456-databasesemployeestest>file.sql
C.mysqldump-uroot-p123456-databaseemployee>file.sql
D.mysqldump-uroot-p123456--all-databases>file.sql
6.远程执行mysqldump命令的界定格式进行备份,那么()。
A..sql文件和.txt文件都在client端
B..sql文件和.txt文件都在server端
C..sql文件记录在client端,.txt文件记录在server端
D..sql文件记录在server端,.txt文件记录在client端
7.设置日志清理时间为5天的命令正确的是( )。
A.setexpire_logs_days=120
B.setglobalexpire_logs_days=120
C.setexpire_logs_days=5
D.setglobalexpire_logs_days=5
8.使用loaddata…infile命令后报错“Datatruncatedforcolum…”,出现的原因可能是()。
A.插入数据的过程中违反了唯一性约束
B.数据存储的文件中列的类型与数据库中表的类型不一致
C.数据存储的文件中的主键值数据库中已经存在
D.数据存储的文件中部分字段存在NULL值
9.在进行InnoDB崩溃恢复的过程中,希望在恢复过程中不执行插入缓冲的合并操作,那么innodb_force_recovery参数的值应该设置为()。
A.3
B.4
C.5
D.6
10.对于不同存储引擎的数据表的描述错误的是()。
A.MyISAM存储引擎不支持事务和行级锁
B.InnoDB存储引擎的数据表
C.MySQL中的存储引擎都不支持并发插入
D.Memory存储引擎支持内存表的实现
11.MySQL中,可以用于备份数据库的命令是( )。
A.mysqlimport
B.mysqldump
C.mysql
D.copy
12.下面关于mysqldump备份特性中说法错误的是( )。
A.是逻辑备份,需将表结构和数据转换称SQL语句
B.备份与恢复速度比物理备份快
C.mysql服务必须运行
D.支持MySQL所有存储引擎
13.事务故障的恢复的步骤包括( )。
A.正向扫描日志文件,建立撤销队列和重做队列
B.反向扫描日志文件,查找此事务的更新操作
C.对事务的更新操作执行逆操作
D.分别对撤销队列和重做队列执行相应的操作
14.下列关于查看MySQL二进制日志文件的命令正确的是( )。
A.selectbinarylogs
B.selectmasterlogs
C.showbinarylogs
D.showmasterlogs
15.关于文件系统冷备份的说法正确的是( )。
A.文件系统冷备份就是直接使用操作系统提供的命令对文件进行拷贝
B.文件系统冷备份只需要拷贝相关的数据文件即可
C.对于InnoDB存储引擎的数据表中的数据文件包含在根目录下的ibdata*文件中,在文件系统冷备份过程中需要拷贝此文件
D.要备份只有MyISAM存储引擎的数据库,只需要复制数据库对应名称的目录下的数据文件,不需要复制ibdata*文件
16.关于loaddatainfile命令和mysqlimport命令的说法正确的是()。
A.mysqlimport支持SQL文件的导入
B.mysqlimport本质上是loaddatainfile的命令接口
C.mysqlimport可以导入多张表
D.两种方法都可以导入select…intooutfile导出的文件
17.关于InnoDB崩溃恢复说法正确的是()。
A.InnoDB崩溃恢复借助于InnoDB引擎的Redo和Undo日志
B.InnoDB的恢复过程是在MySQL线程中进行的
C.多数情况下,InnoDB会自觉地执行线程恢复
D.发生系统故障后,仍然能够执行InnoDB崩溃恢复
18.系统管理员维护了一个远程服务器的数据库ED,数据库中有多张表,表的创建语句为:
createtableemployees(
emp_noint(11)primarykey,
birth_datedate,
first_namevarchar(14),
last_namevarchar(16),
genderenum(‘M’,’F’),
hire_datedate);
createtabledepartments(
dept_nochar(4)primarykey,
dept_namevarchar(40));
其中连接数据库的用户名为root,密码为123456。
(1)2019年5月15日对数据库ED进行备份,其命令为
19.(2)2019年5月16日上午10:00误操作删除数据库ed中的数据表employees,语句为
20.(3)之后,又向数据库departments中插入两条数据。
21. (4)此时数据库中只有一个二进制日志文件mysql-bin.000001,此时利用(2)的备份文件以及二进制文件还原表和数据,需要执行的操作是
国开学习网《数据库运维》第6章本章自测答案
1.连接到MyTop的命令是( )。
A.Mytop-urootpasswordtest
B.Mytop-userrootpasswordtest
C.mytop-uroot-ptest-ddatabase
D.mytopuroot-passwordtest
2.关于连接检查指标以下说法错误的是()。
A.Aborted_connects表示连接失败的次数
B.Threads_running表示运行连接数量
C.Connection_errors_internal表示超出最大限制而失败的连接数
D.Threads_connected表示当前连接数量
3.MySQL默认的存储引擎为( )。
A.MyISAM
B.MEMORY
C.InnoDB
D.FEDERATED
4.以下哪个数据库保存所有的临时表和临时存储过程()。
A.tempdb数据库
B.master数据库
C.model数据库
D.msdb数据库
5.以下关于数据库性监视,错误的说法是()。
A.数据库性能监视不仅要监视MySQL当前的状态,还需监视OS的状态
B.Nagios可以监视操作系统的状态
C.监视工具可以分为非交互性和交互性
D.Innotop和MyTop属于非交互性监视工具
6.MySQL支持以下哪种情况的子查询优化( )。
A.简单SELECT查询中的子查询
B.带有GROUPBY、HAVING、聚集函数
C.使用ORDERBY中带有LIMIT
D.内表、外表的个数超过MySQL支持的最大表的连接数
7.使用下列哪个字符串作为Like谓词后的表达式时不会使用索引( )。
A.abc
B.%abc%
C.abc%
D.a%bc
8.查询代价的估算公式为()。
A.r*pages*a_page_cpu_time+(1-r)W*T
B.pages*a_page_cpu_time
C.W*T
D.pages*a_page_cpu_time+W*T
9.以下不适合使用聚集索引的情况是()。
A.频繁修改索引的列
B.外键列
C.主键列
D.列经常被分组排序
10.TIMESTAMP的默认值是()。
A.0000-00-00
B.0000-00-0000:00:00
C.00-0000:00
D.null
11.以下哪个命令用于查看SQL语句会作用于哪些分区()。
A.EXPLAIN
B.SHOWGLOBALSTATUS
C.EXPLAINDEFINATION
D.EXPLAINPARTITIONS
12.MySQL数据库中,列的相关信息存储于()文件当中。
A..idb
B..MYD
C..opt
D..frm
13.将外连接消除转化为内连接的好处是( )。
A.节省更多的磁盘空间
B.内连接的操作所需要的时间低于内连接
C.优化器可以更好地选择多表连接顺序,降低IO消耗
D.可以使SQL语句更加直观易懂
14.常用的逆规范化技术有以下哪种()。
A.增加冗余列
B.增加派生列
C.重新组表
D.分割表
15.以下哪些方法可以减少对MySQL的访问次数()。
A.避免重复检索
B.使用查询缓存
C.使用Cache层
D.避免修改数据
16.数据库性能监视的主要指标有()。
A.吞吐量
B.并发量
C.网络流量
D.响应时间
17.MySQL中的sys_schema库中存储以下哪些信息()。
A.Innodb相关信息
B.IO使用情况
C.连接与会话信息
D.索引信息
18.查看MySQL中正在运行的线程可以更准确地定位问题并解决问题。
(1)请使用root用户登录并查询当前正在运行的所有线程
19.(2)请写出杀死线程ID为x的命令
20.(3)请写出查询所有状态不为sleep线程的命令
21.简单购物系统涉及如下表:1.产品表(数据量10w,稳定)2.订单表(数据量200w,且有增长趋势)3.用户表(数据量100w,且有增长趋势)
请以mysql为例讲述下如何进行拆分。
国开学习网《数据库运维》第7章本章自测答案
1.在主服务器数据库上创建用户账号并授权的命令grantreplicationslaveon*.*to'user'@'10.21.69.237'identifiedby'1'中,用于从数据库连接主数据库的账号名是()。
A.“.”
B.10.21.69.237
C.user
D.1
2.主数据库的进行服务器ID等相关配置的文件是()。
A.my.ini
B.mysql-relay-bin.index
C.my.txt
D.master.info
3.查看复制线程的语句是( )。
A.SHOWPROCESSLIST
B.SHOWPROCESS
C.SHOWSLAVESTATUS
D.上述都不是
4.下列关于复制过滤描述正确的是()。
A.复制过滤就是对用于复制的数据进行过滤,允许复制服务器上的全部数据
B.过滤方式包括在主数据库上过滤记录到中继日志中的事件
C.过滤方式包括在从数据库上过滤记录到二进制日志中的事件
D.在主数据库上可以使用选项binlog_do_db来控制过滤
5.下列关于二进制日志文件与中继日志文件的描述错误的是( )。
A.中继日志文件用于保存节点自身产生的事件
B.中继日志文件则是保存接收来自其他节点的事件(也是二进制格式的)
C.中继日志文件拥有与二进制日志文件相同的结构,可以通过mysqlbinlog命令解析
D.中继日志文件也有一个日志的索引文件
6.从数据库服务器中I/O线程的作用是( )。
A.中继日志文件的管理
B.保存节点自身产生的事件
C.保存接收来自其他节点的事件
D.访问主数据库的二进制文件存放在中继日志文件中
7.与复制模式一致,二进制日志在记录事件时也支持三种格式,由( )参数控制。
A.binlog
B.binlog_format
C.log_bin
D.sync_binlog
8.状态文件relay-log.info的主要作用是( )。
A.保存处理进度及中继日志文件的位置
B.保存处理进度及二进制日志文件的位置
C.保存复制环境中连接主数据库节点的配置信息
D.记录磁盘上的二进制日志文件
9.显示复制线程状态(分行显示)的命令是( )。
A.Showslavestatus
B.Showslavestatus\g
C.Showmasterstatus\G
D.Showmasterlogs
10.下列有关中继日志文件介绍错误的是( )。
A.中继日志文件和日志文件索引的保存路径可以通过--relay-log和--relay-log-index参数进行自定义
B.中继日志文件拥有与二进制日志文件不同的结构
C.遇到了从数据库节点主机名修改的情况时,可以通过修改中继日志、相关日志文件名的方式解决
D.启动Slaves节点I/O线程时会触发创建新的中继日志文件,并更新相关的索引文件
11.为了实现主数据库二进制文件在从数据库的复用在从服务器中引入了( )。
A.中继日志文件
B.二进制日志文件
C.I/O线程
D.SQL线程
12.在MySQL复制中,复制模式分为哪几种( )。
A.基于关键字的复制模式
B.基于语句的复制模式
C.基于行的复制模式
D.混合记录模式
13.除了中继日志文件之外,复制环境中的从数据库节点还会创建两个复制环境的状态文件分别是( )。
A.master.info
B.xtrabackup_slave_info
C.mysql-bin.index
D.relay-log.info
14.使用主数据库备份的方法包括( )。
A.冷备份
B.热备份
C.使用mysqldump
D.使用快照或者备份
15.主从同步过程中,从数据库可能发生错误并导致数据不一致的原因可能是( )。
A.网络中断
B.服务器崩溃
C.MySQL的Bug
D.服务器非正常关闭
16.简述MySQL主从复制的具体原理以及流程。
17.MySQL主从复制过程中进行管理和维护的方法有哪些并简要描述。

网友评论